Автор Тема: Настройка Калькуляции  (Прочитано 5149 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sherbakov

  • Ветеран
  • *****
  • Сообщений: 650
      • Просмотр профиля
Настройка Калькуляции
« : 02 Март 2014, 12:28:31 »
Написал тут небольшой мануал к калькуляции) Вернее мое виденье калькуляции. Вообще тема обьемна...

Оффлайн Альберт

  • Новичок
  • *
  • Сообщений: 24
      • Просмотр профиля
Re: Настройка Калькуляции
« Ответ #1 : 03 Август 2015, 17:57:11 »
Добрый день!
В отчете "Калькуляция" программа считает монтаж в 100 раз больше.
В встроенных константах Монтаж% установлено "18". В отчете "Калькуляция" считает 1800%.
Где нужно подкорректировать формулу монтажа, чтобы считало правильно?

Оффлайн Альберт

  • Новичок
  • *
  • Сообщений: 24
      • Просмотр профиля
Re: Настройка Калькуляции
« Ответ #2 : 03 Август 2015, 18:15:35 »
Всё, вопрос решил.
Во вкладке "Калькуляция" прописал Монтаж=Монтаж%/100*СтоимостьРамы.

Оффлайн DimSan

  • Новичок
  • *
  • Сообщений: 11
  • Пол: Мужской
      • Просмотр профиля
Re: Настройка Калькуляции
« Ответ #3 : 08 Март 2022, 00:09:18 »
Можно описать все переменные которые можно использовать

Оффлайн DimSan

  • Новичок
  • *
  • Сообщений: 11
  • Пол: Мужской
      • Просмотр профиля
Re: Настройка Калькуляции
« Ответ #4 : 08 Март 2022, 00:15:10 »
Не могу настроить калькуляцию чтоб выполнялись условия зависящие от площади и наличия фурнитуры

Оффлайн Алексей

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 745
  • Пол: Мужской
      • Просмотр профиля
Re: Настройка Калькуляции
« Ответ #5 : 14 Март 2022, 22:50:36 »
Маржа=Маржа*КоличествоИзделий
Перем пр
пр=ПлощадьРамы/КоличествоИзделий
Если пр<=1.3 То
  Если ФурнитураЦена>0 То
    Маржа=Маржа*2
  Иначе
   Маржа=Маржа*1.5
  КонецЕсли
ИначеЕсли пр<1.5 То
  Если ФурнитураЦена>0 То
    Маржа=Маржа*2.5
  Иначе
   Маржа=Маржа*2
  КонецЕсли
ИначеЕсли пр>=2 То
  Если ФурнитураЦена>0 То
    Маржа=Маржа*3
  Иначе
   Маржа=Маржа*2.5
  КонецЕсли
КонецЕсли