Окна Плюс II

Главная категория => Модуль по расчету изделий => Тема начата: sherbakov от 02 Март 2014, 12:28:31

Название: Настройка Калькуляции
Отправлено: sherbakov от 02 Март 2014, 12:28:31
Написал тут небольшой мануал к калькуляции) Вернее мое виденье калькуляции. Вообще тема обьемна...
Название: Re: Настройка Калькуляции
Отправлено: Альберт от 03 Август 2015, 17:57:11
Добрый день!
В отчете "Калькуляция" программа считает монтаж в 100 раз больше.
В встроенных константах Монтаж% установлено "18". В отчете "Калькуляция" считает 1800%.
Где нужно подкорректировать формулу монтажа, чтобы считало правильно?
Название: Re: Настройка Калькуляции
Отправлено: Альберт от 03 Август 2015, 18:15:35
Всё, вопрос решил.
Во вкладке "Калькуляция" прописал Монтаж=Монтаж%/100*СтоимостьРамы.
Название: Re: Настройка Калькуляции
Отправлено: DimSan от 08 Март 2022, 00:09:18
Можно описать все переменные которые можно использовать
Название: Re: Настройка Калькуляции
Отправлено: DimSan от 08 Март 2022, 00:15:10
Не могу настроить калькуляцию чтоб выполнялись условия зависящие от площади и наличия фурнитуры
Название: Re: Настройка Калькуляции
Отправлено: Алексей от 14 Март 2022, 22:50:36
Маржа=Маржа*КоличествоИзделий
Перем пр
пр=ПлощадьРамы/КоличествоИзделий
Если пр<=1.3 То
  Если ФурнитураЦена>0 То
    Маржа=Маржа*2
  Иначе
   Маржа=Маржа*1.5
  КонецЕсли
ИначеЕсли пр<1.5 То
  Если ФурнитураЦена>0 То
    Маржа=Маржа*2.5
  Иначе
   Маржа=Маржа*2
  КонецЕсли
ИначеЕсли пр>=2 То
  Если ФурнитураЦена>0 То
    Маржа=Маржа*3
  Иначе
   Маржа=Маржа*2.5
  КонецЕсли
КонецЕсли